2.0/ProcessMaker Installation Requirements

From ProcessMaker
Jump to: navigation, search

Contents

Introduction

This manual will guide you to check the necessary resources not only Hardware but also Software requirements in order to install ProcessMaker. This is focused according to every available distributions.

Installation Requirements

Hardware Requirements

Hardware requirements may vary based on the number of concurrent users, repository size and system configuration. Larger implementations may require some configuration tuning to perform optimally. For more information, see ProcessMaker Server Sizing. For production use, it is recommended that ProcessMaker be installed in a dedicated server or virtual machine.

Server and Workstations

Refer to ProcessMaker Server Sizing documentation.

Software Requirements

Operating System

  • GNU/Linux (CentOS 5.2, Debian, OpenSuse, RedHat)
  • Windows (XP, Vista, 7, Server 2003, Server 2008)

Web Server

  • Linux: Apache 2.2.3 or greater
  • Windows: Apache 2.2.16 to 2.2.20 or later.

Both with the following modules enabled

    • deflate
    • expires
    • rewrite
    • vhost_alias

Database

For ProcessMaker 1.6 or previous:

  • MySQL: 4.1.2 or greater

     (If using the Pentaho Reports plugin, MySQL 5.1.6 or greater is required.)

For ProcessMaker 1.8 or greater:

  • MySQL: 5.1.6 or greater

It is recommended to install phpMyAdmin or a similar program to easily access the MySQL databases used by ProcessMaker with a web browser.

For ProcessMaker 2.5 or greater:

  • MySQL: 5.1.6

Note: Although ProcessMaker can connect to other databases such as Oracle, SQL Server and PosgreSQL, MySQL needs to be installed to store information about processes, users and reports.

Language

  • For version 2.5 or later, PHP 5.3 is required
  • For version 2.0.45 or earlier, PHP 5.2.10 is required
  • PHP 5.4 is not supported yet

The following modules must be enabled:

    • mysql
    • xml
    • mbstring
    • mcrypt
    • soap: necessary if using web services
    • ldap: (necessary if integrating with LDAP or Active Directory)
    • gd: recommended if using Events
    • curl: necessary for uploading/downloading files.

Note: From PHP version 5.3 curl module is not installed by default, depending on the distribution it must be compiled.

Browser Compatibilty

The following web browsers are recommended for use with ProcessMaker:

ProcessMaker Version Recommended Web Browsers Observations
1.X FireFox 1.0-3.6,
Internet Explorer 7-8
Known problems with Internet Explorer 9.
2.0.0 – 2.0.31 FireFox 1.0-3.6,
Internet Explorer 7-8
Several problems with Internet Explorer 9. Chrome has problems with numeric fields and date fields. Safari was not tested.
2.0.32 - 2.0.35 FireFox 1.0-5.0,
Internet Explorer 7-9
Chrome has problems with numeric fields and date fields. Safari was not tested.
2.0.36 - 2.0.37 FireFox 1.0-8.0,
Internet Explorer 7-9,
Chrome
Chrome 16 was tested. Safari and FireFox 9.0+ have not been tested.
2.0.37 - 2.0.38 Firefox 5
Internet Explorer 7-9,
Chrome 16
-
2.0.38 - 2.0.39 Firefox 10.0.2
Internet Explorer 9.0.5 ,
Chrome 17.0.963.66 m
Safari5.1.2
Opera11.61
-
2.0.39 - 2.0.40 Firefox 11.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.39 - 2.0.40 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.40 - 2.0.41 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.41 - 2.0.42 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.42 - 2.0.43 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.42 - 2.0.43 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.43 - 2.0.44 Firefox 13.0
Internet Explorer 9.0.8 ,
Chrome 18.0.1025.162
-
2.0.43 - 2.0.45 Firefox 15.0.2
Internet Explorer 9.0.8 ,
Chrome 22.0
Known issues with Internet Explorer 10, it is not recommended to use this version.
2.5.0 Firefox 20.x
Internet Explorer 8.0 and 9.0 ,
Google Chrome 26.0.x
Known issues with Internet Explorer 10, it is not recommended to use this version.
2.5.1 Firefox 20.x
Internet Explorer 8.0 and 9.0 ,
Google Chrome 26.0.x
Known issues with Internet Explorer 10, it is not recommended to use this version.
2.5.2 Firefox v.26
Internet Explorer 8.0 and 9.0 ,
Google Chrome v.31
Known issues with Internet Explorer 10, it is not recommended to use this version.


Personal tools
Versions
ProcessMaker Editions
Share This