The following stacks are supported by ProcessMaker 2.x, meaning that they have been tested by the Quality Control team. For ProcessMaker 3.0, please refer to this page.

ProcessMaker Version Stack 101 Stack 102 Stack 103 Stack 104
CentOS CentOS 6.3
Windows Windows Server 2008 R2 Windows 7 Windows Server 2008 R2
PHP PHP 5.3 PHP 5.3 PHP 5.3 PHP 5.3
Apache/IIS Apache 2.2.x Apache 2.2.x Apache 2.2.x IIS 7
MySQL MySQL 5.1 MySQL 5.1 MySQL 5.1 MySQL 5.1

Note: ProcessMaker can be installed in other stacks, such as Debian 7 and Ubuntu 14.04 LTS, but they haven't undergone the same level of testing by the ProcessMaker Quality Control team.